KoolReport's Forum

Official Support Area, Q&As, Discussions, Suggestions and Bug reports.

What is the minimum laravel version for integrating koolreport? #1539

Open Tech Apps opened this topic on on Jul 22 - 6 comments

Tech Apps commented on Jul 22

What is the minimum laravel version for integrating koolreport?

Tech Apps commented on Jul 22

im using laravel version is 5.2.45, what is the koolreport/pro version can i install?

KoolReport commented on Jul 23

Hi, Laravel 5 is fine.

Tech Apps commented on Jul 23

but, koolreport/pro package is not getting installed. getting error

KoolReport commented on Jul 23

May I know the error you get?

Tech Apps commented on Jul 24

$ composer update Loading composer repositories with package information Updating dependencies (including require-dev) Your requirements could not be resolved to an installable set of packages.

Problem 1

- Conclusion: remove laravel/framework v5.2.45
- Conclusion: don't install laravel/framework v5.2.45
- Conclusion: don't install laravel/framework v5.2.44
- Conclusion: don't install laravel/framework v5.2.43
- Conclusion: don't install laravel/framework v5.2.42
- Conclusion: don't install laravel/framework 5.2.41
- Conclusion: don't install laravel/framework v5.2.40
- Conclusion: don't install laravel/framework v5.2.39
- Conclusion: don't install laravel/framework v5.2.38
- Conclusion: don't install laravel/framework v5.2.37
- Conclusion: don't install laravel/framework v5.2.36
- Conclusion: don't install laravel/framework v5.2.35
- Conclusion: don't install laravel/framework v5.2.34
- Conclusion: don't install laravel/framework v5.2.33
- Conclusion: don't install laravel/framework v5.2.32
- Conclusion: don't install laravel/framework v5.2.31
- Conclusion: don't install laravel/framework v5.2.30
- Conclusion: don't install laravel/framework v5.2.29
- Conclusion: don't install laravel/framework v5.2.28
- Conclusion: don't install laravel/framework v5.2.27
- Conclusion: don't install laravel/framework v5.2.26
- Conclusion: don't install laravel/framework v5.2.25
- Conclusion: don't install laravel/framework v5.2.24
- Conclusion: don't install laravel/framework v5.2.23
- Conclusion: don't install laravel/framework v5.2.22
- Conclusion: don't install laravel/framework v5.2.21
- Conclusion: don't install laravel/framework v5.2.20
- Conclusion: don't install laravel/framework v5.2.19
- Conclusion: don't install laravel/framework v5.2.18
- Conclusion: don't install laravel/framework v5.2.17
- Conclusion: don't install laravel/framework v5.2.16
- Conclusion: don't install laravel/framework v5.2.15
- Conclusion: don't install laravel/framework v5.2.14
- Conclusion: don't install laravel/framework v5.2.13
- Conclusion: don't install laravel/framework v5.2.12
- Conclusion: don't install laravel/framework v5.2.11
- Conclusion: don't install laravel/framework v5.2.10
- Conclusion: don't install laravel/framework v5.2.9
- Conclusion: don't install laravel/framework v5.2.8
- Conclusion: don't install laravel/framework v5.2.7
- Conclusion: don't install laravel/framework v5.2.6
- Conclusion: don't install laravel/framework v5.2.5
- Conclusion: don't install laravel/framework v5.2.4
- Conclusion: don't install laravel/framework v5.2.3
- Conclusion: don't install laravel/framework v5.2.2
- Conclusion: don't install laravel/framework v5.2.1
- cviebrock/eloquent-taggable dev-master requires illuminate/database ^7.0 -> satisfiable by illuminate/database[v7.0.0, v7.0.1, v7.0.2, v7.0.3, v7.0.4, v7.0.5, v7.0.6, v7.0.7, v7.0.8, v7.1.0, v7.1.1, v7.1.2, v7.1.3, v7.10.0, v7.10.1, v7.10.2, v7.10.3, v7.11.0, v7.12.0, v7.13.0, v7.14.0, v7.14.1, v7.15.0, v7.16.0, v7.16.1, v7.17.0, v7.17.1, v7.17.2, v7.18.0, v7.19.0, v7.19.1, v7.2.0, v7.2.1, v7.2.2, v7.20.0, v7.21.0, v7.3.0, v7.4.0, v7.5.0, v7.5.1, v7.5.2,

v7.6.0, v7.6.1, v7.6.2, v7.7.0, v7.7.1, v7.8.0, v7.8.1, v7.9.0, v7.9.1, v7.9.2].

- cviebrock/eloquent-taggable dev-master requires illuminate/database ^7.0 -> satisfiable by illuminate/database[v7.0.0, v7.0.1, v7.0.2, v7.0.3, v7.0.4, v7.0.5, v7.0.6, v7.0.7, v7.0.8, v7.1.0, v7.1.1, v7.1.2, v7.1.3, v7.10.0, v7.10.1, v7.10.2, v7.10.3, v7.11.0, v7.12.0, v7.13.0, v7.14.0, v7.14.1, v7.15.0, v7.16.0, v7.16.1, v7.17.0, v7.17.1, v7.17.2, v7.18.0, v7.19.0, v7.19.1, v7.2.0, v7.2.1, v7.2.2, v7.20.0, v7.21.0, v7.3.0, v7.4.0, v7.5.0, v7.5.1, v7.5.2,

v7.6.0, v7.6.1, v7.6.2, v7.7.0, v7.7.1, v7.8.0, v7.8.1, v7.9.0, v7.9.1, v7.9.2].

- don't install illuminate/database v7.0.0|don't install laravel/framework v5.2.0
- don't install illuminate/database v7.0.1|don't install laravel/framework v5.2.0
- don't install illuminate/database v7.0.2|don't install laravel/framework v5.2.0
- don't install illuminate/database v7.0.3|don't install laravel/framework v5.2.0
- don't install illuminate/database v7.0.4|don't install laravel/framework v5.2.0
- don't install illuminate/database v7.0.5|don't install laravel/framework v5.2.0
- don't install illuminate/database v7.0.6|don't install laravel/framework v5.2.0
- don't install illuminate/database v7.0.7|don't install laravel/framework v5.2.0
- don't install illuminate/database v7.0.8|don't install laravel/framework v5.2.0
- don't install illuminate/database v7.1.0|don't install laravel/framework v5.2.0
- don't install illuminate/database v7.1.1|don't install laravel/framework v5.2.0
- don't install illuminate/database v7.1.2|don't install laravel/framework v5.2.0
- don't install illuminate/database v7.1.3|don't install laravel/framework v5.2.0
- don't install illuminate/database v7.10.0|don't install laravel/framework v5.2.0
- don't install illuminate/database v7.10.1|don't install laravel/framework v5.2.0
- don't install illuminate/database v7.10.2|don't install laravel/framework v5.2.0
- don't install illuminate/database v7.10.3|don't install laravel/framework v5.2.0
- don't install illuminate/database v7.11.0|don't install laravel/framework v5.2.0
- don't install illuminate/database v7.12.0|don't install laravel/framework v5.2.0
- don't install illuminate/database v7.13.0|don't install laravel/framework v5.2.0
- don't install illuminate/database v7.14.0|don't install laravel/framework v5.2.0
- don't install illuminate/database v7.14.1|don't install laravel/framework v5.2.0
- don't install illuminate/database v7.15.0|don't install laravel/framework v5.2.0
- don't install illuminate/database v7.16.0|don't install laravel/framework v5.2.0
- don't install illuminate/database v7.16.1|don't install laravel/framework v5.2.0
- don't install illuminate/database v7.17.0|don't install laravel/framework v5.2.0
- don't install illuminate/database v7.17.1|don't install laravel/framework v5.2.0
- don't install illuminate/database v7.17.2|don't install laravel/framework v5.2.0
- don't install illuminate/database v7.18.0|don't install laravel/framework v5.2.0
- don't install illuminate/database v7.19.0|don't install laravel/framework v5.2.0
- don't install illuminate/database v7.19.1|don't install laravel/framework v5.2.0
- don't install illuminate/database v7.2.0|don't install laravel/framework v5.2.0
- don't install illuminate/database v7.2.1|don't install laravel/framework v5.2.0
- don't install illuminate/database v7.2.2|don't install laravel/framework v5.2.0
- don't install illuminate/database v7.20.0|don't install laravel/framework v5.2.0
- don't install illuminate/database v7.21.0|don't install laravel/framework v5.2.0
- don't install illuminate/database v7.3.0|don't install laravel/framework v5.2.0
- don't install illuminate/database v7.4.0|don't install laravel/framework v5.2.0
- don't install illuminate/database v7.5.0|don't install laravel/framework v5.2.0
- don't install illuminate/database v7.5.1|don't install laravel/framework v5.2.0
- don't install illuminate/database v7.5.2|don't install laravel/framework v5.2.0
- don't install illuminate/database v7.6.0|don't install laravel/framework v5.2.0
- don't install illuminate/database v7.6.1|don't install laravel/framework v5.2.0
- don't install illuminate/database v7.6.2|don't install laravel/framework v5.2.0
- don't install illuminate/database v7.7.0|don't install laravel/framework v5.2.0
- don't install illuminate/database v7.7.1|don't install laravel/framework v5.2.0
- don't install illuminate/database v7.8.0|don't install laravel/framework v5.2.0
- don't install illuminate/database v7.8.1|don't install laravel/framework v5.2.0
- don't install illuminate/database v7.9.0|don't install laravel/framework v5.2.0
- don't install illuminate/database v7.9.1|don't install laravel/framework v5.2.0
- don't install illuminate/database v7.9.2|don't install laravel/framework v5.2.0
- Installation request for laravel/framework 5.2.* -> satisfiable by laravel/framework[5.2.41, v5.2.0, v5.2.1, v5.2.10, v5.2.11, v5.2.12, v5.2.13, v5.2.14, v5.2.15, v5.2.16, v5.2.17, v5.2.18, v5.2.19, v5.2.2, v5.2.20, v5.2.21, v5.2.22, v5.2.23, v5.2.24, v5.2.25, v5.2.26, v5.2.27, v5.2.28, v5.2.29, v5.2.3, v5.2.30, v5.2.31, v5.2.32, v5.2.33, v5.2.34, v5.2.35, v5.2.36, v5.2.37, v5.2.38, v5.2.39, v5.2.4, v5.2.40, v5.2.42, v5.2.43, v5.2.44, v5.2.45, v5.2.5, v5.2.6, v5.2.7, v5.2.8, v5.2.9].
- Installation request for cviebrock/eloquent-taggable dev-master -> satisfiable by cviebrock/eloquent-taggable[dev-master].
David Winterburn commented on Jul 27

Hi,

If you remove koolreport/pro from your composer's require, does composer update alright?

Build Your Excellent Data Report

Let KoolReport help you to make great reports. It's free & open-source released under MIT license.

Download KoolReport View demo
help needed

Laravel